Boot da pendrive usb con UEFI Bios

This post is also available in: enInglese

Con l’introduzione di Windows 8 è stato anche messo da parte il vecchio BIOS, per introdurne una versione più ricca e versatile, ossia l’UEFI.

Con il “nuovo Bios” (firmware UEFI) troveremo qualche difficoltà ad avviare il pc (o notebook) da una pendrive usb, lettore CD/DVD o hard disk esterno, in quanto nell’UEFI è integrata la funzione Secure Boot che si occupa di bloccare malware che potrebbero attaccare il sistema nella fase pre-boot, ma impedisce anche l’installazione delle varie distribuzioni Linux e di tutti i sistemi operativi non certificati.

Se vogliamo avviare, quindi, il nostro pc da una periferica esterna, dovremo cambiare delle impostazioni sul nostro firmware UEFI.

Vediamo come avviare il nostro pc da: USB, lettore CD/DVD o hard disk esterno:

N.B. Queste indicazioni, in linea di massima, possono essere applicate a tutti gli UEFI anche se in genere, questi, sono leggermente differenti tra loro a secondo delle case costruttrici.

  • Per prima cosa, inseriamo il supporto dal quale vogliamo effettuare il boot;
  • Entriamo nel bios (se non sai come fare, leggi l’articolo Entrare nel Bios Windows 8, 8.1 e 10);
  • In base al Bios, cerchiamo la voce Modalità Legacy oppure Launch CSM. Attivando la modalità legacy, tutte le funzioni legate all’UEFI, vengono disabilitate. Mentre l’abilitazione del Launch CMS ci permetterà di avviare qualsiasi sistema operativo (solitamente troviamo uno o l’altro in base al modello del pc);
  • Adesso andiamo a disabilitare due voci: FAST BOOT e SECURE BOOT;
  • Come ultimo step, spostiamoci sulla sezione BOOT e modifichiamo la sequenza di boot, secondo le nostre esigenze;
  • Clicchiamo su Save changes and Exit – OK.
  • Al prossimo riavvio il pc verrà avviato dalla periferica scelta precedentemente.

Adesso possiamo procedere ad installare qualsiasi sistema operativo!!

N.B. Non è consigliabile effettuare modifiche al Bios se non si sa chiaramente quello che si sta facendo! La redazione Geek’s Lab non si assume alcuna responsabilità su errori o danni!!

Se ti piacciono i nostri articoli seguici su: Facebook , Twitter e G+!!

  • Tracerbound

    Ottima guida

  • Angelica

    Ciao, ho windows 10 Home 64 bit versione 10.0.1439 su un HP Pavilion 15 n°219 sl.Ho installato windows 8 EnterpriseEva in un hard disk esterno. Da esplora risorse di windows 10 risultano tutti file inseriti nell’ hard disk e la procedura di installazione è risultata correttamente eseguita. Ho seguito la procedura che hai descritto ma non c’è verso di avviare da USB external hard disk. L’unica cosa che non ho potuto fare è di disabilitare la voce Fast boot in quanto non è presente nelle opzioni del mio BIOS. Hai qualche altro consiglio? Grazie

    • Geek’s Lab

      Quale procedura hai utilizzato per installare Windows 8 su hd esterno?

      • Angelica

        Ho usato Diskpart per preparare l’hd esterno. ho usato Windows Easy Install per l’intallazione sull’hd al termine della quale mi si dice installazione correttamente eseguita, riavvia per concludere l’intallazione. Al riavvio sono entrata nel Bios ed ho seguito la tua procedura. A forza di tentativi finalmente sono riuscita un paio di volte a fare partire dall’hd esterno ma ogni volta con un errore diverso

        • Geek’s Lab

          E’ possibile che l’installazione non sia andata a buon fine? Che errore ricevi quando riavvii?

          • Angelica

            Ricordo più o meno una scritta del genere: Windows failed to start. Info: The boot configuration data file doesn’t contain valid file for an operating sistem.

          • Geek’s Lab

            Perchè non provi a reinstallare Windows 8 tramite Aomei Partition Assistant?

          • Angelica

            Provato anche con AOMEI ma niente da fare dall’HD esterno non parte. Con Windows Easy Install ho scoperto che nella ISO del sistema operativo col quale mi sto scervellando, il file Install.win è in una cartella zippata denominata Install e classificata come archivio win. Ho rinominato la cartella zippata in Install.win e in questo momento sto aspettando che termini l’installazione. Non so se funzionerà anche perché al termine mancherebbero 2 ore e mezza. Come avrai capito sono un incompetente in materia perciò spero di non far perdere a nessuno del tempo inutilmente

          • Geek’s Lab

            ciao, non preoccuparti. Se possiamo, siamo felici di aiutare. Non puoi scaricare un’altra iso?

          • Angelica

            Certo ,credi non lo abbia fatto? Per la serie “Non me ne va bene una” su tre iso che ho scaricato tutte hanno Install in file zippato. Ho provato a scaricare anche dal portale ufficiale Windows però ( e già figuriamoci se non trovavo un intoppo) al momento di inserire il product key (numero preso dal retro di un notebook in mio possesso e che non uso da almeno 4 anni) non vengono riconosciuti validi. Cioè rileva che appartengono ad un sistema operativo preinstallato sul pc e dovrei contattare il produttore…….e che cavoloooo!

          • Angelica

            Ho risolto! Mi è bastato rinominare il file compresso da install a install.win usando Windows Easy Install per avviare da Hard disk esterno. Grazie a tutti voi per l’aiuto

          • Geek’s Lab

            Perfetto!! Grazie a te! Continua a seguirci! 🙂

          • Geek’s Lab

            Prova con questa procedura. La puoi seguire anche se a tua ISO è per Windows 8. https://www.geekslab.it/installare-windows-10-su-hard-disk-esterno/

  • Enrico Bonfatti

    Ciao, ho appena acquistato un netbook Mediacom Smartbook con SSD da 32 GB; vorrei provare una distro ubuntu su pendrive,ma entrando nei settaggi di boot non riesco a trovare l’opzione di disabilitazione del secure boot; più chenon trovarla devo dire che non c’è proprio, ormai ho guardato dappertutto. Si può intervenire in qualche altro modo?

  • Marco Filipozzi

    Ciao
    Ho bisogno di una mano, vi racconto il mio problema.
    Ho comprato da qualche mese un 2 in 1 cinese, un cube i9, una sorta di clone del Microsoft Surface Pro, bella macchina ad un prezzo onesto.
    Leggendo vari post su xda, mi sono accorto che la batteria non viene ricaricata al 100% ma solo al 70% circa, e questo è dovuto al bios, che andrebbe reinstallato con una versione custom che ho già trovato.
    Il problema è che per semplificare l’installazione devo far avviare il tablet da una chiavetta usb dove inserirò lo script per sostituire il bios.
    Sono entrato nel bios ma non riesco a capire bene cosa devo selezionare:
    E’ corretto disabilitare fastboot e selezionare full inizial da USB support?
    Basta questo?
    Ho letto di un programma che si chiama rufus, secondo voi fa al mio caso oppure non è necessario?
    Allego sia il thread di xda che le immagini del bios del mio tablet
    Se mi risolvete sto grattacapo vi faccio una statua https://uploads.disquscdn.com/images/51950d6ea9d7be9b24df79da9c4e4695f9ae965aac4117290136e7117a4be406.jpg
    https://uploads.disquscdn.com/images/7f6ff8ef6407b709f15aa53397c2106ba5fb8f13a6e082c89c915b925d96ef25.jpg
    https://forum.xda-developers.com/showpost.php?p=66085361&postcount=5
    grazie mille
    😀

    • Geek’s Lab

      Ciao, ho dato un’occhiata alla guida che mi hai linkato. Per prima cosa ti anticipo che è un’operazione che ha dei rischi. Spero tu abbia controllato la validità di questi file. Purtroppo non avendo il device in questione non possiamo testare direttamente. Non ci assumiamo quindi nessuna responsabilità. Detto questo, ecco quello che dice di fare la guida Xda:
      1. Formatta una chiavetta usb in fat32 e copia il contenuto dell’archivio su di essa.
      2. Adesso, devi avviare la da usb il tuo pc
      3. Se il pc si è avviato correttamente da usb, la procedura partirà automaticamente.
      Per mettere i file nella chiavetta devi semplicemente fare un copia incolla dopo averla formattata (quindi rufus non ti serve). Per avviare il pc da usb devi disattivare il Secure Boot e il Fast Boot. Mi sembra di non vedere dagli screen la voce Legacy o Launch CMS o sbaglio?

      • Marco Filipozzi

        Innanzitutto grazie mille per la risposta.
        So che l’operazione è rischiosa, ma mi fido abbastanza di xda e il tablet così com’è non mi soddisfa al 100%, il mio è un rischio consapevole.
        Come hai notato anche tu, il Fast Boot l’ho trovato, ma il Secure Boot no.
        Ho provato anche a cercare nei vari Boot Option#1 e #2 ma niente Legacy né Launch CMS.
        Un utente in un altro forum che tratta il cube i9 dice questo
        “in order to boot from a usb pen you have to choose gpt for uefi in rufus as partiton schema”
        quindi ho pensato che forse questo programma rufus poteva ovviare il problema dell’avvio da USB
        https://techtablets.com/forum/topic/how-do-you-enter-bios-on-cube-i9/
        scusa ma ho dei problemi con l’inglese, capisco il senso generale della frase, ma mi sfuggono i termini troppo tecnici

        • Geek’s Lab

          Ok Secure Boot e Fast Boot disattivali. Adesso prova a selezionare la pendrive su Boot Option #1 (nel frattempo do un’occhiata al link che mi hai mandato).

          • Marco Filipozzi

            Eccomi ancora qua, stavo per procedere all’installazione del bios quando, per scrupolo, sono andato in un forum e sto scovato questo post
            https://techtablets.com/forum/topic/i-bricked-my-cube-i9-dont-look-in-bios-flashing-menu/
            Ho cercato di tradurlo, e mi sono un po’ spaventato.
            il tizio stava cercando di fare la stessa operazione che vorrei fare io, ma qualcosa è andato storto. Lui afferma di aver sbagliato, ma non ho capito cosa. Ti posso chiedere ancora una mano? Grazie mille per la tua gentilezza

          • Geek’s Lab

            Ciao, purtroppo con il bios non si scherza. Bisogna capire anche quale guida abbia usato per arrecare il danno. Mi dispiace non poterti dare altro aiuto.

          • Marco Filipozzi

            Alla fine mi sono fatto coraggio ed ho provato, ma niente, non riesco a far avviare il tablet dall’USB. Ho disattivato sia fast boot che secure boot, ma niente. Ho letto in giro dell’ override boot, ne sai qualcosa? Mi pare di capire che puoi dare la priorità di boot, ma questa vale solo per il primo riavvio, poi torna quella di default

          • Geek’s Lab

            Certo. Dopo aver disabilitato il fast boot e secure boot devi impostare il Boot da usb. Dovresti guardare su Boot Option.

          • Marco Filipozzi

            Buone nuove
            😀
            Sono finalmente riuscito ad installare il nuovo bios, grazie al tuo aiuto.
            E’ andato a buon fine quando ho capito che non bastava scompattare solo il file .rar contenente lo script, ma dovevo anche estrarlo dalla cartella, pensa che rimba che sono.
            Ora setto di nuovo le impostazioni del bios com’erano prima. Grazie ancora
            Dalle mie parti si dice: Ti devo una birra
            😀

          • Geek’s Lab

            Grazie a te per la fiducia! Speriamo che l’aggiornamento porti i benefici previsti!!
            Continua a seguirci 🙂

          • alex

            buona sera geek….volevo chiedervi se riuscite a dirmi come fare per avviare da usb un tablet teclast x80 plus..premetto che il boot priority è in usb mass storage. perché non ho modo di farlo partire per fare una nuova installazione Windows 10….ho provato a fare una chiavetta con Windows creation toll (si chiama così)?? ma niente da fare , anche se la chiavetta nel bios me la riconosce…uffff!!! aiuto

          • Geek’s Lab

            Salve,
            può inviare delle foto del bios?

      • Marco Filipozzi

        Forse ho trovato
        https://uploads.disquscdn.com/images/16e44c8019ddf61a7319831a975e5a84d51f07afc24020bd958891f96e3464b4.jpg
        la strada è quella?
        La cosa che mi sembra strana è che pare già disabilitato il Secure Boot

  • Jesse Livermore

    Salve, ho un problema vediamo se riusciamo a risolverlo. Ho acquistato un pc senza sistema operativo, ho comprato Windows 10 su chiavetta USB ed installato perfettamente.

    Adesso, per motivi che purtroppo non posso qui spiegare, questo pc mi è stato sottratto ed l’ho riavuto con SSD formattato.

    Ho provato a reinstallare Windows via USB ma mi appare schermata blu con errore 0x000000f avevo pure una chiavetta con l’ultima versione di Windows creata dal MediaCreationTool ma anche questa m da errore uguale al primo…cosa mi consigliate di fare?

    • Geek’s Lab

      Hai provato la chiavetta su diverse porte usb? Se hai la possibilità, prova tramite dvd.

      • Jesse Livermore

        Grazie Geek’s ho provato su un’altra porta usb dove avevo altro dispositivo ed è partita l’installazione…